Left

CivilFEM Online Help

Right

预应力筋编辑器

 

 

一旦定义了支承梁(命令 ~SBBMDEF, ~SBSMDEF y ~SBSMMDF),即可在其上布置预应力筋,并使用预应力筋编辑器创建和修改预应力筋。

 

预应力筋编辑器窗口的结构如下:

 

  

 

 

El 对象树 是结构上定义的预应力筋和点的示意表示。对象树中每个元素的所有属性均可在主窗口的选项卡中查看,其中部分属性可在属性窗口中修改;在此窗口中,灰色显示的数据不可由用户编辑,黑色显示的数据则可以编辑。

主窗口中有三个选项卡。第一个选项卡立面图和平面图显示支承梁的平面视图和立面视图。第二个选项卡剖 面显示支承梁的横截面,第三个选项卡立面图 和数据表显示包含预应力损失数据的表格。

 

窗口顶部有一个工具栏,其外观会根据当前选定的对象而变化。

 

 

Nota: La proyección en planta es una proyección ortogonal del modelo y de los tendones sobre el plano horizontal de referencia, sin embargo, la proyección en alzado es una proyección sobre la directriz longitudinal del puente, no sobre un plano vertical.

 

对象树

 

它包含三个主要组:

 

  • 截面(Cuts)。 它们是支承梁的基本实体。当从梁模型()定义支承梁时,每个截面代表一个节点或构件端部。反之,如果采用实体模型,则该截面与该点捕获的实体截面相关联。
  • 点()。 点位于截面上,预应力筋将布置在这些点上。点分为两组:平面点和立面点。这两组彼此完全独立;例如,某个截面上可以有立面点,而没有对应的平面点,等等。
  • 预应力筋(预应力筋)。在每两个点之间采用二次 Bezier 曲线定义两种几何形状,分别用于平面和立面。

 

在对象树中的不同元素上单击鼠标右键时,将显示快捷菜单,其中列出可对该元素或元素组执行的操作。

 

对于平面点和立面点(),可以执行以下操作:

 

  • 插入新点(插入立面图视点, 插入平面图视点, 插入点)(命令 ~PCEPDEF, ~PCPPDEF).
  • 删除点(删除 点)(命令 ~PCEPDEL, ~PCPPDEL).
  • 复制点(复制 点)(命令 ~PCEPGEN, ~PCPPGEN).
  • 将立面点移动到截面的重心(移动到重心)(命令 ~PCEPMDF).
  • 将立面点移动到上缘或下缘,同时遵守截面中定义的保护层厚度(移动到上缘纤维, 移动到下缘纤维) (命令 ~PCEPMDF).

 

对于预应力筋(预应力筋),快捷菜单可执行以下操作:

 

  • 插入新预应力筋(插入预应力筋)(命令 ~PCTNDEF).
  • 删除预应力筋(删除 预应力筋)(命令 ~PCTNDEL).
  • 复制预应力筋(复制 预应力筋)(命令 ~PCTNGEN).
  • 在预应力筋中插入新 点(插入点)(命令 ~PCTNMDF).
  • 从预应力筋中删除一个 点(删除点)(命令 ~PCTNMDF).
  • 复制点(复制 点)(命令 ~PCEPGEN, ~PCPPGEN).
  • 将立面图中的点移动到截面的重心(移动到重心)(命令 ~PCEPMDF).
  • 将立面图中的点移动到上缘纤维或下缘纤维,同时遵守剖面中定义的保护层厚度(移动到上缘纤维, 移动到下缘纤维) (命令 ~PCEPMDF).

 

还可以使用以下工具调整预应力筋的几何形状:

 

  • 直线段 更改斜率(Set straight line -> Align slopes)。从 选定点向预应力筋的下一个点绘制直线,并 修改这两个点的斜率(命令 ~PCTNMDF).
  • 直线段 更改第一个点(Set straight line -> Change 1st point)。 从选定点的下一个点向选定点绘制直线, 并更改选定点的坐标和斜率(命令 ~PCTNMDF).
  • 直线段 更改第二个点(Set straight line -> Change 2nd point)。 从选定点向下一个点绘制直线,并 更改下一个点的坐标和斜率(命令 ~PCTNMDF).
  • 抛物线段 更改第一个点的斜率(Set parabola -> Change 1st slope)。更改选定点的斜率,使 预应力筋在选定点与预应力筋中定义的下一个点之间形成竖直轴抛物线(命令 ~PCTNMDF).
  • 抛物线段 更改第二个点的斜率(Set parabola -> Change 2nd slope)。更改选定点的下一个点的斜率, 使预应力筋在选定点与预应力筋中定义的下一个点之间形成竖直轴抛物线(命令 ~PCTNMDF).

 

Nota: Al modificar las propiedades (coordenadas o pendientes) de un punto, todos los tendones que pasen por dicho punto se verán afectados.

 

 

属性窗口

 

此窗口 位于对象树下方,具有以下三个功能:

 

  • 显示每个选定对象或对象组的 属性。每次选定对象(剖面、点、预应力筋等)时,窗口都会显示 其全部属性。
  • 允许修改 数据。选定对象的某些属性可以更改。 只需编辑属性窗口中的相应 单元格即可。
  • 在特定操作中充当对话框。 在某些情况下,例如创建一个 点,需要输入一系列数值或属性 才能执行选定操作。属性窗口会改变外观, 变为用于输入这些数据的对话框。

 

 

工具栏

 

窗口顶部为工具栏。工具栏由一组按钮和下拉列表组成。工具栏 分为两部分:固定部分在预应力筋定义过程中的任何时刻都保持不变;可变部分 根据具体情况进行调整,仅显示当前可用的按钮。

 

工具栏的 固定部分如下:

 

                                        退出 并保存所做的更改。

                                        退出 而不保存更改。

                                        保存 更改。

                                        展开 此帮助文档。

                                 撤销 (undo)或重做(redo)最近执行的更改。

                                         计算 预应力损失(命令 ~PCLOSS).

                                        列出 钢束属性(一般属性、点和损失)(命令 ~PCTNLST).

       立面视图 的比例。

              平面视图 的比例。

 

工具栏的可变部分包含一系列按钮,这些按钮会根据当前情况、当时选中的元素等逐步启用。这些按钮可执行的功能与在对象树中通过单击鼠标右键显示的上下文菜单执行的功能相同。

 

 

Elevation and Plan View 选项卡

 

立面视图和平面视图:

 

右键菜单为上下文菜单,工具栏中也提供了相应功能

 

 

钢束编辑器的这两个部分用于在模型上以图形方式表示剖面、点和钢束。垂直比例可通过工具栏。 在这两个窗口中的任意一个窗口上单击鼠标右键,将显示包含以下选项的上下文菜单:

 

 

  • 放大: 将图像以鼠标单击点为中心进行放大。
  • 缩小: 缩小图像。
  • 框选缩放: 通过在窗口中单击两个点定义矩形,可指定要放大的区域。
  • Fit: 图形窗口恢复为原始设置,显示图形的全部范围。
  • 自动-Fit: 启用此选项后,即使更改窗口大小,也会显示图形的全部范围。
  • 移动: 移动窗口中的图形内容。
  • 距离: 计算窗口中两点之间的距离。结果显示在窗口底部的状态栏中。当鼠标指针接近模型的特征点时,CivilFEM 将自动将其位置调整到这些点上。
  • 角度: 计算由三个点定义的两个线段之间的角度。结果显示在窗口底部的状态栏中。当鼠标指针接近模型的特征点时,CivilFEM 将自动将其位置调整到这些点上。

 

要查看横截面,可以在某个剖切面上单击鼠标右键,或单击工具栏中的 View Cross Section 按钮,或切换到 Cross Section 选项卡。

 

 

 

Cross Section 选项卡

 

此选项卡显示选定剖切面处的横截面,显示预应力筋,并可对预应力筋的部分数据进行调整。

 

 

 

Elevation and Data Table 选项卡

 

此选项卡显示预应力产生的损失数据。 图表显示用户在属性窗口中选择的数据。此选项卡仅用于信息显示,因此不能编辑有关支承梁的任何数据,只能编辑显示选项。

 

 

 

 

 

 

相关命令:

~PCEPDEF

~PCEPDEL

~PCEPGEN

~PCEPMDF

~PCLOSS

~PCPPDEF

~PCPPDEL

~PCPPGEN

~PCPPMDF

~PCTNDEF

~PCTNDEL

~PCTNGEN

~PCTNLST

~PCTNMDF

~SBBMDEF

~SBSMDEF

~SBSMMDF